Get in touch
Back
Maintenance

KSA Production Environment

Completed .

Application Portal - KSA LinkSDK - KSA Link API - KSA Data/Payments API - KSA
Completed

Maintenance completed

Posted .
Started

We would like to inform you that we are planning a maintenance activity as per the details below:

Details: KSA Production Environment
Start Time: July 2, 2025, at 21:30 UTC Time
End Time: July 2, 2025, at 23:30 UTC Time
Impact: Short periods of service degradation in this timeframe.

Apologies for any inconvenience caused.

Posted .