Get in touch
Back
Resolved

Temporary Service Disruption Notice: 2 March 2026

Started .

Data/Payments API - UAE
Created

The region is currently experiencing temporary service disruption due to downtime from AWS in the region.
Lean itself is not hosted on AWS but many banks are currently experiencing an outage.
As a result, certain banks/services may be intermittently unavailable. We are closely monitoring developments and will resume normal operations as soon as services are restored.
We appreciate your patience and understanding during this time. Further updates will be shared as information becomes available.

Posted .